info@techdevops.com
TechDevOps.com
Explore Tools
Experts in Microsoft SQL Server Operations, Performance, Replication, Cloud & Migrations



The selected Subscriber does not satisfy the minimum version compatibility level of the selected publication
by BF (Senior MSSQL Operations - Enterprise, Cloud, Strategy)
2015-08-11







Error message:

"The selected Subscriber does not satisfy the minimum version compatibility level of the selected publication"
can occur when you are setting up a Replication Subscriber from a SQL Server 2008 R2 Publisher to a SQL Server 2014
Subscriber using the older SQL Server Management Studio version (SQL Server 2008 R2).

This error is caused by SQL Server Management Studio.


Solution:

Use the SQL Server Management Studio of SQL Server 2014 server instead of SQL Server 2008 R2 server. This will allow you to setup the Subscriber.